macd零轴选股公式

问:跪求大神macd周线0轴以上的选股公式

这个条件选股可以有两种方啊

第一种写选股公式,再条件选股里选股周期选周线,

XG:(EMA(CLOSE,12)-EMA(CLOSE,26)>EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9))*(MAX(EMA(CLOSE,12)-EMA(CLOSE,26),EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9))<2.5);

第二种综合选股,设置如下图.

把三个条件都加入进去选股周期选周线.

问:MACD零轴上横盘选股公式

首先macd是均线趋势指标,macd0轴上就是红柱时,一定是上升趋势,而不是盘整,盘整形态时,macd的表现一定是一会红柱一会绿柱.
但可以选择dif值大于0时盘整,
公式如下
N:=15;
M:=5;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
T1:=HHV(H,N)/LLV(L,N)-1<=M/100;
XG:T1=1&&COUNT(DIF>0,N)=N;
n是盘整的时间周期范围,m是盘整的涨跌幅度,n15,m5就是,盘整幅度在15天,盘整幅度不大与百分之5,同时盘整时dif值一直在0轴之上

问:求一个通达信选股公式,只需要MACD在零轴附近的

{M 0 1 0.1}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
ABS(MACD)<M;
随便起个名字就可以了。
你要求的,macd在±0.5之间,感觉有点大,默认值设的是0.1.
祝你股市顺利!

问:求通达信公式:MACD在零轴上方,且白线黄线很近的选股公式?

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

XG:MACD>0 AND DIF-DEA<0.1 AND DIF>DEA;


你设计这样的条件会出现大量金叉时或者死叉前dif与dea离的很近符合选股条件.
如果你要是想选dif与dea一段时间离的很近,缺少时间条件.
至于在30分钟选还是60分钟选,可以在选股周期里选择

问:跪求各位高手:通达信macd月线0轴下金叉,周线在0轴上状态的公式,谢谢。

月DIF:="MACD.DIF#MONTH";
月DEA:="MACD.DEA#MONTH";
月MACD:="MACD.MACD#MONTH",COLORSTICK;
周DIF:="MACD.DIF#WEEK";
周DEA:="MACD.DEA#WEEK";
周MACD:="MACD.MACD#WEEK",COLORSTICK;
XG:月DIF<0 AND CROSS(月MACD,0) AND 周MACD>0;

问:MACD在零轴上金叉的次数?

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);DEA:EMA(DIF,9);MACD:(DIF-DEA)*2,COLORSTICK;DRAWICON(DIF>0 AND CROSS(DIF,DEA),0,1);零轴上金叉次数:IF(DIF>0,SUM(CROSS(DIF,DEA),IF(DIF>0,BARSLAST(CROSS(DIF,0))+1,0)),0),NODRAW;

DRAWNUMBER(DIF>0 AND CROSS(DIF,DEA),DIF,零轴上金叉次数),COLORGREEN;