通达信距离今天天数,通达信公式里如何可以获取最近一段时间最高点那天到今天的天数

  Q1:通达信公式里如何可以获取最近一段时间最高点那天到今天的天数

VAR1:=H=HHV(H,50);
BARSLAST(VAR1);
50天内最高点,到今天的天数。

  Q2:通达信 如何描述条件成立那天到今天的天数?

上一次条件成立到当前的周期数.
用法:
BARSLAST(X):上一次X不为0到现在的天数
例如:BARSLAST(CLOSE/REF(CLOSE,1)>=1.09958)表示上一个涨停板到当前的周期数
你可以试试

  Q3:请问通达信:15天以前第一个死叉距今的天数 怎么编写?

M5:=MA(C,5);
M10:=MA(C,10);
FF15:BARSLAST(CROSS(M10,M5))<14;{死叉距今的天数}

  Q4:通达信选股公式如何定义上上次5、20日均线金叉距离今日的天数,

MA5:=MA(CLOSE,5); //定义5日均线
MA20:=MA(CLOSE,20); //定义20日均线
T1:=CROSS(MA5,MA20); //定义5,20金叉
T2:=BARSLAST(T1); //上次金叉到现在的天数
XG:BARSLAST(REF(T1,1)); //上上次金叉到现在的天数
测试通过,谢谢采纳

  Q5:求通达信选股公式 从某一天开始至今,中间任意一天超过那天的股价,谢谢

指定:=170718;{指定日期,例:17年07月18日。根据需要自定修改}
SJ:=DATETODAY(DATE)-DATETODAY(1000000+指定);
GG:=IF(SJ=0,H,0);
A1:=BARSSINCE(GG>0);
超过了:BARSLASTCOUNT(H>REF(GG,A1))=1;

  Q6:通达信 某天到某天总共有几个交易日 如何计算和设置

没有条件怎么选股啊,
下面的公式能统计,某年某月某日到某年某月某日之间有多少个交易日
你想统计什么时间直接修改起始时间和结束时间就可以了
起始:=20180510;
结束:=20190510;
X:BARSLAST(起始=DATE+19000000)-BARSLAST(结束=DATE+19000000)NODRAW;